Changes in master shapes are not updated on diagram

VISIO

    Sponsored Links

    Next

  • 1. Problem with Visio 2003/Exchange 2003 Org Chart Integration
    I hope you can help me with a problem I am having with the org chart integration between Visio 2003 SP1 and Exchange 2003 with no service packs installed. When I make the org chart, it generates all of the managers, but loses some of their subordinates. For instance, I have one manager with three subordinates. When I run the wizard on that manager only two subordinates are returned. I have checked via Outlook 2003 SP1 and Active Directory and all of the subordinates are set there properly to their manager. Can anyone think of anything I can do to correct this? Thank you, Mr. X
  • 2. Downloads for version 2002
    Does anyone know how I can find templates (specifically software development templates) for version 2002. According to "Visio 2002 Inside-Out" the templates I need were removed from version 2002 but should be available as downloads from Microsoft. Unfortunately I can't find them.
  • 3. Problem with Dragging-Dropping Classes from Model Explorer
    After working on my drawing for a while, I have several packages full of classes. When I drag-drop one of the classes from the model explorer onto a diagram, the class drawing appears but the model explorer tree does not update to show the class as a child of that diagram. I can cut/copy-paste a class and have everything work correctly. Has this happened to anyone else? If yes, could the behaviour be corrected?
  • 4. Visio Crashing
    I have a Visio document that used to work fine. I now come to work on it again and the following happens: (Database model) 1. When I open the document in Visio (or do try to do some other function) Visio opens up multiple times. (Only in 2002 version). 2. When the document is open, if I try to save (whatever version I try to save it in) Visio shuts down with no error (2002 and .NET Enterprise). 3. Random crashes for example when trying to copy objects. 4. If I create a new document and insert the original as Insert File, it copies the objects but with no properties - for example the foreign keys and indexes show on the drawing but no properties including columns exist for a table. Tried a fresh install of 2002, tried renaming, saving as different formats etc, copying the drawing using Select All. Worries me that this happens in both 2002 and .NET Enterprise! (and 2002 on two machines). Can anyone help me as the database this document designs is meant to be created today at the start of the project! Thanks in advance for any help, Becks

Changes in master shapes are not updated on diagram

Postby quiquepe » Fri, 31 Oct 2003 07:38:56 GMT

Hi, using Visio 2003 here. I open a new diagram, open an stencil, drag
some shapes on the diagram. Then I edit the master shape for one of
the shapes that I have on the diagram, and save the changes to the
master. Isn't it expected that the master shape changes should be
reflected on the diagram? . Well, it doesn't. I think the same happens
with Visio 2000 and 2002. Anyone know how to solve this?

Thanks
Quiquepe

Re: Changes in master shapes are not updated on diagram

Postby Al Edlund » Wed, 05 Nov 2003 12:13:16 GMT

update it from files => shapes => document stencil. The master is copied to
the internal stencil and then the local copies inherit from there. Per
Graham Widemans Book..
Al







Similar Threads:

1.when update master shape, instances on page not updated

I'm making a diagram with many shapes on it, all with the same fill, text 
style, line, and connector locations. I need the flexibility to be able to 
update them all at once if, for example, I change the fill color or add a 
couple of connection points.  I'm using Visio Pro 2003 SP2.

I thought the solution was to make a new master shape, but I can't make the 
shapes already on the page update to match the master when I change the 
master. Here's what I did so far:

I carefully followed the help directions to create a new master shape and to 
save the stencil I had it on. I then dragged it on to the page to make 
several instances of that shape in a drawing. Then I edited the master shape 
and re-saved the stencil. The help claims that doing so will automatically 
update any instances of that shape on the page. It did not. 

So I read a little further and found that you can also supposedly 
right-click on the instance of the shape on the page and use Format > Style 
and set the Text, Line, and Fill styles back to "use master's format." So I 
did that. That didn't work, either.

Any suggestions?

Jen

2.Update shape instances when master shape is changed

I've got a Visio drawing with about 300 instances of a master shape.  When I
change some of the properties of the master shape it updates all the
instances as expected, after it prompts me for whether I want to update all
the instances of the master shape.

However, I want to make a change to the master shape with some VBA code and
get all the instances to update automatically.  I have written some code
that seems to do this, but it doesn't always update all the instances.
Could someone paste a snippet of code that would do this to check that I am
on the correct lines, and furthermore, is there a way in VBA to tell it to
update all the instances after a change has been made to the master shape
(as the prompt would usually do, if the changes were made manually to the
master).

Many thanks.

PugWash


3.Getting shape instances to update when master's dimensions are changed

I have a shape master that is a rectange with some text inside it.
When I edit it to make it longer (to fit more text in it), the instances of
the master on the page do not update.
Can anyone help me with this please?

Many thanks.


4.Diagram not completely updated following changes via automation

I am updating dynamic connectors on my diagram via automation from VBA.
This can be changing the line colour/width/pattern etc of all the
connectors on the diagram. Very occasionally, not all the connectors
are updated. However, zooming out and back in again, the lines are show
correctly. Today this even happened for half a connector. It's as if
visio forgets that it was updating the screen. Has anyone seen anything
like this, is it possible for me to force a refresh.

Thanks



Return to VISIO

 

Who is online

Users browsing this forum: No registered users and 19 guest