Add-in ... failed to load or caused an exception

Visual Studio .Net

    Next

  • 1. Reflecting on Types in Project Assemblies - follow up
    A follow-up: When I scan for CodeClass objects at design-time, the scan includes all the namespaces in the project, both the ones in the project source code and ones included through references to external assemblies. I can use the CodeClass objects to retrieve Type name information. That's fine, but in order to produce assembly-qualified Type names (i.e., Type names that include the assembly name) I need to know the name of the assembly where a class is defined. I haven't been able to find a way to do that. Looking at the CodeClass2.ProjectItem.ContainingProject property doesn't work, because it's not defined for external assembly references. Is there some other property of a CodeClass object, or a related object in the CodeElements namespace, which contains this information? Maybe the CodeElements namespace focuses totally on just namespaces, and ignores the "assembly of origin" of the items it describes. - Mark
  • 2. add->tableadapter is grey
    In my dataset when I have a table without a dataadapter I cannot add one to the table. The add->tableadapter popup menu item is grey. How can I add it in the ide? Thanks Bart
  • 3. newbie: trouble connecting to sql server
    VS 2003 .NET OS XP pro, sp2 I've installed Sql Server 2005 Express on this computer and tryed to connect to Sql Server 2005 Express from the IDE of VS 2003 but in the Data Link Properties window I get this error message: "[DBNETLIB][ConnectionOpen(Connect()).]SQL Server does not exist or access is denied" I get the message when trying to open the combobox where I can select a database on my server (my computer, localhost) What am I doing wrong here? I created a simple database in Sql Server 2005 Express, this is all I've done to the database: create database test; I know a database contains much more than this but I hoped I anyway should be able to get it listed in VS .2003 Data Link Property window..... Jeff
  • 4. dependency not found
    I am working in vs.net 2003 with a solution that contains many projects (23 to be exact). I am now getting a dependency error on 2 dlls when compiling through the IDE. I am thinking this has something to do with the build order. However, I am unsure how to proceed from this point. How do I figure out which project within the solution needs its order changed. I have seen newsgroups that refer to checking the error message detail. But I am not sure how to do this through the IDE. Can anyone give me some advice on how to debug this? Thanks in advance, Linda

Add-in ... failed to load or caused an exception

Postby U3RldmUgRWxtZXI » Wed, 29 Mar 2006 01:02:04 GMT

Hi, 

I am trying to use the MSDE 2000 Deployment Toolkit with VS.NET 2005. The 
toolkit includes a VS.NET Addin.  After some research, I discovered that 
VS.NET 2005 is using a different means to register Addins. Basically it seems 
to require an .Addin file (xml). I created a M2KBSLC.Addin file (see below 
for the contents), and placed it in the same folder as the M2KBSLC.dll file. 
In VS.NET 2005, under Options, I added the path to the list of places VS 
looks for Addins. 

The "MSDE 2000 Boostrap Loader Configurator" now shows up in my VS.NET 2005 
Add-in Manager but it is broken. I can check it, but when I click OK in the 
Add-in Manager I get the following error: 

"The Add-in 'MSDE 2000 Bootstrap Loader Configurator' failed to load or 
caused an exception. Would you like to remove this Add-in? If you choose yes, 
the file it was loaded from, 'C:\Program Files\Microsoft\MSDE 2000 Deployment 
Toolkit\M2KBSLC.Addin', will be renamed. 

Error Message: <Unknown Error> 
Error number: 80131513" 



Here is my best shot at an M2KBSLC.Addin file: 

<?xml version="1.0" encoding="UTF-8" standalone="no"?> 
<Extensibility xmlns=" http://www.**--****.com/ "> 
    <HostApplication> 
        <Name>Microsoft Visual Studio</Name> 
        <Version>8.0</Version> 
    </HostApplication> 
    <HostApplication> 
        <Name>Microsoft Visual Studio Macros</Name> 
        <Version>8.0</Version> 
    </HostApplication> 
    <Addin> 
        <FriendlyName>MSDE 2000 Bootstrap Loader Configurator</FriendlyName> 
        <Description>This add-in is used for the installation of MSDE 
2000.</Description> 
        <AboutBoxDetails>Copyright 2005.</AboutBoxDetails> 
        <AboutIconData></AboutIconData> 
        <Assembly src="file">C:\Program Files\Microsoft\MSDE 2000 Deployment 
Toolkit\M2KBSLC.dll</Assembly> 
        <FullClassName>M2KBSLC.Connect</FullClassName> 
        <LoadBehavior>0</LoadBehavior> 
        <CommandPreload>0</CommandPreload> 
        <CommandLineSafe>0</CommandLineSafe> 
    </Addin> 
</Extensibility> 

Any thoughts, helpful hints, and/or suggestions will be appreciated. 

Thanks, 
Steve


Re: Add-in ... failed to load or caused an exception

Postby Carlos J. Quintero [VB MVP] » Wed, 29 Mar 2006 17:14:47 GMT

Hi Steve,

That exception means that something failed in the OnConnection method of the 
add-in, or even before, while the add-in was being loaded (due to COM 
registration problems if the add-in used COM registration).

You will need to debug it with the source code or to contact the 
manufacturer. At the very least, an exception handler should be added to the 
OnConnection method to show the actual exception.

-- 

Best regards,

Carlos J. Quintero

MZ-Tools: Productivity add-ins for Visual Studio
You can code, design and document much faster:
 http://www.**--****.com/ 



"Steve Elmer" < XXXX@XXXXX.COM > escribien el mensaje 


>> Hi,
>>
>> I am trying to use the MSDE 2000 Deployment Toolkit with VS.NET 2005. The
>> toolkit includes a VS.NET Addin.  After some research, I discovered that
>> VS.NET 2005 is using a different means to register Addins. Basically it 
>> seems
>> to require an .Addin file (xml). I created a M2KBSLC.Addin file (see below
>> for the contents), and placed it in the same folder as the M2KBSLC.dll 
>> file.
>> In VS.NET 2005, under Options, I added the path to the list of places VS
>> looks for Addins.
>>
>> The "MSDE 2000 Boostrap Loader Configurator" now shows up in my VS.NET 
>> 2005
>> Add-in Manager but it is broken. I can check it, but when I click OK in 
>> the
>> Add-in Manager I get the following error:
>>
>> "The Add-in 'MSDE 2000 Bootstrap Loader Configurator' failed to load or
>> caused an exception. Would you like to remove this Add-in? If you choose 
>> yes,
>> the file it was loaded from, 'C:\Program Files\Microsoft\MSDE 2000 
>> Deployment
>> Toolkit\M2KBSLC.Addin', will be renamed.
>>
>> Error Message:<
>> Error number: 80131513"
>>
>>
>>
>> Here is my best shot at an M2KBSLC.Addin file:
>>
>><
>>< xmlns=" http://www.**--****.com/ ;>
>>   <
>>       <Microsoft Visual Studi<
>>       <8.<
>>   <
>>   <
>>       <Microsoft Visual Studio Macro<
>>       <8.<
>>   <
>>   <
>>       <MSDE 2000 Bootstrap Loader 
>> Configurato<
>>       <This add-in is used for the installation of MSDE
>> 2000<
>>       <Copyright 2005<
>>       <
>>       <ggf1_1();

RE: Add-in ... failed to load or caused an exception

Postby v-garych » Wed, 29 Mar 2006 17:41:37 GMT

Hi Steve,

Just as the error message implies, the problem happens while the VS2005 IDE 
loads the MSDE 2000 Bootstrapper Loader Configurator Add-in. Your 
registration xml file is all right, it has already registered that addin to 
the VS2005, so you can find it in the IDE's Add-in Manager list.

Since the MSDE 2000 Bootstrapper Loader Configurator Add-in is designed for 
VS.NET 2003, and it has also used the functionality of the IDE command 
bar's, it is not fully compatible with the VS2005 IDE. To migrate such an 
addin to VS2005, its code must be update and recompiled by Visual Studio 
2005.

In this regard, I am afraid that addin could be upgraded to VS2005.

Thanks!

Best regards,

Gary Chang
Microsoft Community Support
======================================================
PLEASE NOTE the newsgroup SECURE CODE and PASSWORD will be updated at 9:00 
AM PST, February 14, 2006.  Please complete a re-registration process by 
entering the secure code mmpng06 when prompted. Once you have entered the 
secure code mmpng06, you will be able to update your profile and access the 
partner newsgroups.
==================================================
When responding to posts, please "Reply to Group" via your newsreader so 
that others may learn and benefit from your issue. 
==================================================
This posting is provided "AS IS" with no warranties, and confers no rights. 


RE: Add-in ... failed to load or caused an exception

Postby U3RldmUgRWxtZXI » Wed, 29 Mar 2006 22:22:02 GMT

I finally ended up contacting the person who wrote the MSDN technical article 
describing the use of the MSDE 2000 Deployment Toolkit 
( http://www.**--****.com/ ). 
 Unfortunately, his reply indicated that Microsoft will not be updating the 
Toolkit for VS 2005.  Nor will there be an update for the SQL Server 2005 
Express edition.

grr...

-Steve





Similar Threads:

1.Outlook Add-In failed to load (during load an runtime error occured)

Hello NG,

I developed a Outlook Add-In but I got a few problems with the installer I 
think.
Outlook starts and the Addin is loaded but stops working. If I check the 
COM-Add-In dialog the plugin is unchecked. Then I mark it and an error is 
shown, wich tells me that during load an runtime error occured and plugin is 
disabled. On my develop machine everything works fine.
So I think maybe the installer is not correct.
The vstor.exe is deployed on my testmachine and .net security policy is set 
to unristricted for the application, when I do the evaluate assembly 
option...

Has anyone an idea...
Thank a lot.

best regards
Oliver 


2.SmtpMail.Send causes exception: Error loading type library/dll

I'm having this error after reinstalling VS. When using SmtpMail.Send I get 
an error. I was searching about this and I see that there's an error with my 
CDO.dll library: it's not registred. How can I register the library?

Diego F.



3.Exception causes load event to end

Hi guys and gals

I'm having a wierd problem with my application. I'm calling a few functions 
and subs from my main load event, and everything works just fine - except 
when one of functions throws an exception (which is handled by the function 
itself).

When an exception has ocured (and been handled) in one of the functions, and 
the rest of the code, in the main load event should run - northing happens. 
It's like the rest of the load event just had been completely forgotten.

What could be the problem here?

Regards Sren Schimkat

4.Adding Label Control causes CDialog to fail

I am using Visual Studio .Net 2003 and I am editing a 
CDialog box with the Dialog Editor. If I add a Microsoft 
Label ActiveX control to the dialog box the .DoModal call 
will fail with a return code of -1.  Why doesn't this 
work? How do I add a Label or Static Text control where I 
can change the text size, font and Bolding?

Thanks for help.

5.Adding TableStyle to Datagrid causes Databinding Exception?

"Peter" < XXXX@XXXXX.COM > wrote in message news: XXXX@XXXXX.COM ...
> Hello,
> 
> Thanks for reviewing my question.  Here is a puzzler.  If I add a Tablestyle 
> to my datagrid (which is bound to a dataset) and close my form in the 
> designer, I receive the following error: "Exception: Databinding could not 
> find a row in the list that is suitable for all bindings".  What is this all 
> about?

Do you have a CurrencyManager declared and passed to the DataGridTableStyle?

- carl

6. Adding Image at runtime causes exception

7. VSTO ribbon add-in causes Windows 2007 to load very slowly

8. CreateChildControls and Exception Failed to Load ViewState



Return to Visual Studio .Net

 

Who is online

Users browsing this forum: No registered users and 6 guest