hard disk can not always be recognized on windows ce net 4.2 and x86 platform

windows ce

    Next

  • 1. Clean build in WinCE 5.0
    Sajid, I use the following script file (clean.bat) which I created: @echo off rem rem this script file will remove all the intermediate build files and the relevant output rem files associated with the current windows ce platform. rem rem place the file in the platform builder cepb\bin folder rem eg. rem C:\Program Files\Microsoft\Platform Builder\CEPB\BIN rem rem to use this script file: rem . from within platform builder open the release dir (command prompt) rem . type CLEAN then press the enter key rem cd %_WINCEROOT% echo clean .obj files del /S /F /Q *.obj echo clean the build log files del /S /F /Q build.err del /S /F /Q build.wrn del /S /F /Q build.log echo clean the platform output folder CD %_FLATRELEASEDIR% del /S /F /Q *.* rmdir /s /q %_FLATRELEASEDIR% cls echo clean complete... Regards... P. "sajid" < XXXX@XXXXX.COM > wrote in message news: XXXX@XXXXX.COM ... Hi all, Is there any way to clean[only] a platform in WinCE 5.0 as found in WinCE 4.2 ? regards sajid
  • 2. IP phone & USB keyboard
    Hi, Is there any conflict between USB keyboard and IP phone configuration in CE 4.2? I build a IP Phone Advanced configuration on a Cirrus EP9315 platform. But I can't enter any password at the PIN screen. I can used the USB mouse to move the cursor around. So the USB host and HID must be OK. And at KITL, I can see the kbdhid.dll loaded when I plug in the keyboard. Also, I tested the USB keyboard and the keyboard driver in other configurations and they worked fine. I don't know what have I done wrong then. Thanks for your help! Derek
  • 3. I/O Resource Manager request for IRQ
    I am having problems with the pcmica driver after having included the interrupt support in the production quality OAL in Win CE 5.0 on pxa255. During initialization I receive the following error from the MDD layer: PCMCIA!PCIRequestResourcesEx: I/O Resource Manager request for IRQ 43 with Flag 0 IrqFlag failed I turned on all the debug zones in the OAL, but it does not look like ResourceRequestEx (that is called right before the error message) is calling any routines in the OAL. From msdn it looks like this function allows devices to request exclusive access to sharable resources. The dwFlags argument that my function pass to ResourceRequestEx is 0. What can cause ResourceRequestEx to fail? Should it call functions in my OAL? Regards, Inger
  • 4. CE4.2 - System crash on Event/Mutex creation
    Hi everyone, Problem description > We use windows Ce 4.2 on a PXA255 platform with 64MByte SDRAM and 64MB Flash. > We have an application that creates named events or mutexes without releasing/closing them. > After a while the system totally crashes when the 65536th handle is being created. > The crash = system hangs without generating exceptions (Nothing appears on the debug output to indicate a crash or exception) > Here is a code sample that easily makes the system crash!!! (Crash ocurs each time when counter reaches exactly 65536) DWORD dwCounter = 0; HANDLE hEvent; while(TRUE) { RETAILMSG(1,(TEXT("Creating event %d\r\n"),dwCounter++)); hEvent = CreateEvent(NULL,FALSE,FALSE,TEXT("MY_EVENT_TEST")); if(hEvent != NULL) { SetEvent(hEvent); } else RETAILMSG(1,(TEXT("Failed to createEvent - error = %d\r\n"),GetLastError())); } Questions : 1) Why does this "CreateEvent" or "CreateMutex" function not return an errorcode or an exception? (i.e. ERROR_NOT_ENOUGH_MEMORY) 2) Why does the kernel not prevent such a crash? 3) Are there QFE packs available that solve this problem? 4) Can we change something in the kernel/hal to intercept or to prevent this crash? 5) Can this problem be generated by an unexpected WORD (counter) overflow in the kernel? (65536 = 0x10000) Thanks for all your support, Peter.

hard disk can not always be recognized on windows ce net 4.2 and x86 platform

Postby qcq » Tue, 12 Jul 2005 09:20:46 GMT

when build platform using pb42,hard disk can not always be recognized on
windows ce net 4.2,the following is in detail:


intel815 recognized

intel845g can only be recognized by specifying ide resources and disabling
dma transmission in source files instead
of detecting resources automatically.

sis620(p6sep-me) can not be recognized
even specify ide resources and disable
dma transmission in source files.

can anybody tell me why?



Similar Threads:

1.hard disk can not always be recognized on windows ce net 4.2 and x86 platform

when build platform using pb42,hard disk can not always be recognized on
windows ce net 4.2,the following is in detail:


intel815 recognized

intel845g can only be recognized by specifying ide resources and disabling
dma transmission in source files instead
of detecting resources automatically.

sis620(p6sep-me) can not be recognized
even specify ide resources and disable
dma transmission in source files.

can anybody tell me why?


2.hard disk can not always be recognized on windows ce net 4.2

when build platform using pb42,hard disk can not always be recognized on 
windows ce net 4.2,the following is in detail:


intel815 recognized

intel845g can only be recognized by specifying ide resources and disabling
dma transmission in source files instead
of detecting resources automatically.

sis620(p6sep-me) can not be recognized
even specifying ide resources and disabling
dma transmission in source files.

can anybody tell me why? 




Return to windows ce

 

Who is online

Users browsing this forum: No registered users and 89 guest