CF Cloning via USB to IDE to CF

Windows XP

    Next

  • 1. Trying to load MSDE for Embedded XP
    The message I receive is the following: Microsoft SQL Server Desktop Engine--A strong SA password is required for security resons. Please use SAPWD switch to supply the same. I down loaded the XP Embedded kit from Microsoft but I'm having problems with the database.
  • 2. The Windows XP Embedded Books - any opinions?
    Thus far, there are two books on Windows XPE. They are: Windows XP Embedded Step by Step Windows XP Embedded Advanced Have any of you used either of these? If so, are they worth buying? Thanks
  • 3. Loading drivers and the shell
    Hello, It has fallen in my lap to research a potential problem in our XPE configuration. This is my first time exploring this realm, so please excuse any untoward display of ignorance. The requirement is to boot up into our custom application without giving the user a chance to monkey with anything in the mean time. An attempt, before my time, to launch without Explorer caused application failure due to drivers not being loaded. From what I have read so far, I don't think there is an particular relationship between the shell and drivers, so my guess is that launching Explorer just happens to give the drivers time to load before our app is called. Does this sound right? Could I just write a shell that was essentially ::Sleep(5000); ::CreateProcess(<our exe>)? Could I then launch Explorer later if needed? Am I on the right track, or am I barking up the wrong tree (what's a sentence without multiple metaphors?). Thanks for any and all help, damon
  • 4. Merry Christmas
    I wish all you a Merry Christmas and a Happy New Year. :-) PS: Sorry for using this newsgrup in a non-standard way...

CF Cloning via USB to IDE to CF

Postby Mark Kraft » Fri, 15 Jun 2007 22:21:10 GMT

Hi,

I have a configuration now using a USB to IDE box with an IDE-CF adapter
installed. I also use Acronis True Image to copy a paritioned image to my
CF. This works great. However, my IDE-CF adapter is only good for non-DMA
CF. Does anyone know of an adapter that will handle DMA fixed CF?

Much appreciated

MK



Re: CF Cloning via USB to IDE to CF

Postby Sean Liming (MVP) » Sun, 17 Jun 2007 01:32:40 GMT

You might want to check out ACS -  http://www.**--****.com/ 
They appear to have a DMA supported solution.

Regards,

Sean Liming
www.sjjmicro.com / www.seanliming.com
Book Author - XP Embedded Advanced, XP Embedded Supplemental Toolkit









Similar Threads:

1.WinCE 6.0 and MANAGED Application (catalog CF 2.0 with CF 3.5)

2.Need to downgrade VS2008 with CE c# app from CF 3.5 to CF 2.0

Hi,

I have other posts which explain the serial port issues I am trying to 
resolve.

One way forward may be to target Compact Framework V2 instead of 3.5, but my 
Project properties shows this as grayed out. 

What do I need to do in VS2008 to re-target my app to V2.0 please ??.

Thanks

Regards

Graham

3.RAM-EWF on CF (IDE2) when inserting HDD on IDE1 but still boot from CF

Hi,

I am using Slobodans RAM-EWF component ,

I got CF on second IDE with RAM-EWf and this is works fine when running CF
only, and I am protecting arc path rdisk(0) = CF:

Then I insert a HDD on IDE one, and start this first (BIOS boot order.)
(then the HDD has ARC rdisk 0  )The boot.ini on the HDD has the option to
boot from CF, and so I do. (still ARC rdisk is 0 for HDD and CF rdisk number
changes to 1

Then the CF EWF will now protect the HDD since this is given rdisk 0 path.

How can I make CF always protect itself only, even if the rdisk number
changes ?
Can i fix the rdisk number ?? so it does not change even if new disk is
inserted ?

Thanks

Cato


4.IDE to CF Card Issue

Hi,

I am running windows ce 5.0 on X86 based VIA ETX board. In that i am trying 
to use CF card via IDE to CF card converter. The CF Card is not at all 
detected in the os. ATAPI driver is included in the build. I tried lot of cf 
cards from which only one is detected which is from RiDATA manufacturer. I 
have searched lot in the internet groups. i didn't get any clues. Can anybody 
help me to resolve this? 


Thanks in advance.

5.A question about CF card (IDE interface)!

I use PB4.2 to build my OS image ,add "ATAPI PCI/IDE Storage Block Driver"
and "FAT file system" by drag them from the catalog.
My hardware is x86-based.In this condition ,IDE harddisk and some CF cards
work well,(can read/write ,and displayed in WINCE OS ),but some CF cards
does not work(have no icon in WINCE OS,so can't read or write) .I use a
utility named HWINFO to check the disk information about my CF cards.
I found that, the CF cards that works well only support LBA mode in the
harddisk features,and that can not displayed in the WINCE OS support two or
more features ,such as LBA,DMA,IOROY,and so on .
Does this means that WINCE only support some singel harddisk feature,but not
support the CF cards that hold two or more features well?
How to make my WINCE OS support the CF cards that hold two or more features
?

Any help would be greatly appreciated!
Thanks
smile_lh


6. Version of ATADisk.DLL to support CF microdrives in True-IDE mode

7. IDE CF Desperately slow under WinCE

8. Configuring 2nd CF IDE in PB 4.2



Return to Windows XP

 

Who is online

Users browsing this forum: No registered users and 65 guest